导语: 知我者,谓我心忧;不知我者,谓我何求。 ---> 投稿/删侵: jiangp@fusionskye.com

wordpress升级出现“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限”解决办法

技术 坏得很的糟老头子 631浏览 0评论 本文共2667个字,预计阅读时间需要7分钟。

出现“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限”说到底还是权限的问题,如果你是apache的话,权限设置必须要给足够;否则你升级是不能成功的;

此文适合所有用wordpress的朋友们!不管你是nginx还是apache;

今天在帮朋友安装wordpress的时候,也出现了这样的一个问题,它的服务器环境是:

Centos6.8+Apache2.2.31+MySQL 5.5.48+PHP7.0.7

我最初给的权限是这样的:根目录(wwwroot)我给的是755权限,wp-content我给的是777权限;

1、第一次升级出现的第一个问题:

“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。:wp-admin/includes/update-core.php 安装失败”;

解决办法也很简单,直接给update-core.php 777权限;

chmod 777 update-core.php

2、继续第二次升级又出现另一个问题:

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-admin/js/updates.min.js, wp-admin/js/common.js, wp-admin/js/customize-controls.js, wp-admin/js/common.min.js, wp-admin/js/updates.js, wp-admin/js/customize-controls.min.js, wp-admin/includes/file.php, wp-admin/customize.php, wp-admin/about.php, wp-includes/js/plupload/handlers.min.js, wp-includes/js/plupload/handlers.js, wp-includes/js/wp-api.js, wp-includes/js/wp-api.min.js, wp-includes/class-wp-customize-manager.php, wp-includes/class-http.php, wp-includes/class-wp-xmlrpc-server.php, wp-includes/version.php, wp-includes/taxonomy.php

安装失败

解决办法同样简单,直接给wp-admin文件及子文件777权限;

chmod -R 777 wp-admin

3、继续我的第三次升级,又出现一个问题:

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-includes/js/plupload/handlers.min.js, wp-includes/js/plupload/handlers.js, wp-includes/js/wp-api.js, wp-includes/js/wp-api.min.js, wp-includes/class-wp-customize-manager.php, wp-includes/class-http.php, wp-includes/class-wp-xmlrpc-server.php, wp-includes/version.php, wp-includes/taxonomy.php

安装失败

解决办法依然很简单,直接修改wp-includes权限为777;

chmod -R 777 wp-includes

4、继续再进行我的最后一次升级wordpress,升级成功!

5、如果第4步再次升级没有成功,却出现了如下情况:

正在从http://downloads.wordpress.org/release/zh_CN/wordpress-4.9.4.zip下载更新文件…

正在解压缩升级文件…

正在校验解压的文件…

正在准备安装最新版本…

因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限。: wp-settings.php, wp-cron.php, wp-signup.php, wp-trackback.php, wp-login.php, wp-load.php, wp-activate.php, wp-config-sample.php

安装失败

解决办法同样很简单,只需要给 wp-settings.php, wp-cron.php, wp-signup.php, wp-trackback.php, wp-login.php, wp-load.php, wp-activate.php, wp-config-sample.php 同样的权限777,这样就不会出现存在不一致的文件权限的问题;

[root@localhost html]# chmod 777 wp-settings.php
[root@localhost html]# chmod 777 wp-cron.php
[root@localhost html]# chmod 777 wp-signup.php
[root@localhost html]# chmod 777 wp-trackback.php
[root@localhost html]# chmod 777 wp-login.php
[root@localhost html]# chmod 777 wp-load.php
[root@localhost html]# chmod 777 wp-activate.php
[root@localhost html]# chmod 777 wp-config-sample.php

6、再一次后台更新我的wordpress, 更新成功!

说明:因为我目前来说,很少用lamp环境了,今天也是第一次用lamp环境安装wordpress,由于apache的原因,apache需要的权限和nginx需要的权限是不一样的,因此,如果你需要这种类似的情况,只要是权限不够,缺少什么权限你就给什么权限!如果你实在不懂权限这方面的知识,你直接给777权限;

注意:上面这些目录或文件权限修改为了777升级成功了后,一定要再回去把它的权限修改为755;

总结:由于wordpress这个程序的问题,它升级的时候讲究的是权限必须是一样的,只要有一些文件权限不一样,就会一直提示“这通常是因为存在不一致的文件权限”这个问题;如果你服务器安装了wordpress后,你又经常改了一些权限的话,到时候后台更新起来是非常麻烦的一件事情!只能把所有的文件或目录权限设置成一样的。

转载请注明:Memories.toString » wordpress升级出现“因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件权限”解决办法

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址